Jump to content


Photo

Option to ignore hidden files/folders when uploading


  • Please log in to reply
27 replies to this topic

#1 oeoj

oeoj
  • Members
  • 14 posts

Posted 01 August 2006 - 03:03 AM

It'd be nice to have an option to ignore hidden files or folders when uploading the contents of a folder by adding said folder onto the queue. Or if it could adhere to the system's option of whether to show hidden files or not.

Sometimes I need to upload from a CVS or SVN working copy to an FTP server, and Smart will attempt to upload all the hidden "control" files and folders inside subdirectories even though my XP system is set to not show hidden files. The local file windows will not show the hidden files, but the recursive processing in the queue seems to pick up hidden files / folders despite this.

I realise there's the option to checkout a 'release' copy from such control systems, which excludes all the extra control files, but this can be inconvenient at times when all you want to do is send up one folder with a few minor changes in it with a plan to let Smart handle change detection using checksums.

#2 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 01 August 2006 - 09:05 AM

That's what file exclusion filters are for, see the settings.

#3 oeoj

oeoj
  • Members
  • 14 posts

Posted 01 August 2006 - 11:32 AM

I thought I checked there, but didn't see an option to disregard hidden files, only files by wildcard/regex matched filenames?

I'll double check again tomorrow when I'm back at work.

#4 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 01 August 2006 - 02:59 PM

You are right, there is no option to exclude hidden files. I was meaning to say that the feature you ask for basically is there, with the difference that you need to exclude by name. Just specify ".svn" as a wildcard exclude filter and check to exclude directories, too, and you're set. This way, the ".svn" folder an all its contents will be ignored and not transferred.

#5 oeoj

oeoj
  • Members
  • 14 posts

Posted 01 August 2006 - 11:42 PM

Ah, lateral thinking: 1, me: 0.

Thanks, works for now :unsure:

But, I'd still like to maintain my request to ignore hidden files as there's several other file types similar to this. It's just that the request isn't as urgent as before.

I'm slowly building a list in my filters for the more common ones though, like Thumbs.db and OSX files the start with dot-underscore.

#6 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 August 2006 - 03:19 AM

The FTP client doesn't get any information whether the file is marked as "hidden" on the host system.
Therefore it's not possible now to implemented the requested feature.
Regards,
-Mat
SmartFTP

#7 oeoj

oeoj
  • Members
  • 14 posts

Posted 02 August 2006 - 03:43 AM

This is for the upload queue, Mat. The hidden files in question are on the client system.

#8 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 August 2006 - 04:34 AM

Ah. I see. Will think about it.

Regards,
-Mat

#9 suoperduper

suoperduper
  • Members
  • 35 posts

Posted 06 August 2006 - 06:38 AM

Ah. I see. Will think about it.

Regards,
-Mat



I stumbled across this problem serveral times myself. Files like Thumbs.db being transfered although it did not show on the client computer. Would be nice to have an option to disable the transfer of these files automatically without setting up exclusion filters.

Thx

Stef

#10 MichelleM

MichelleM
  • Members
  • 1 posts

Posted 29 September 2009 - 08:57 PM

Just for the record, because it took me forever to figure out exactly what the filter was, this is how to exclude .svn folders and files for the default favorite. I'm using SmartFTP 3.0.126.7.

- Click Tools > Settings
- Under "General" in the list on the left click "Favorites"
- In the panel on the right, under "Default Favorite" click "Edit"
- Under Options select "Enable" and check the box for "ignore case"
- Under Filter List > Type select "Exclude"
- Click the 'new' button to the right of the word Filter (hover and it will say 'new', it's a sorta dotted-line square icon)
- Copy and paste the following into the Value field: *\.svn*
- Double-click on the words "File (Name)" and a dropdown list will appear. Select "Any" from that list.
- At the bottom of the screen, click "OK" to save your changes.

Hope this helps someone!

#11 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 29 September 2009 - 10:03 PM

Thank you.

The value field is wrong:
WRONG: *\.svn*
CORRECT: *\.svn$

#12 cwd

cwd
  • Members
  • 6 posts

Posted 05 October 2009 - 08:56 PM

I'm noticing that my filter isn't working anymore. Did a recent update change the way the filters work?

I'm using Windows Vista, 64-bit, v4.0.1053.0 and I use the blue "upload/download" arrows to transfer files.

I have, under filter settings for the default favorite:

Enable (ignore case)
Use Favorite's settings (grayed out)
Exclude:
Wildchar | *.svn | Folder (name)
Wildchar | _ts3tmp.php | File (name)

Any ideas?

Edited by cwd, 05 October 2009 - 08:57 PM.


#13 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 05 October 2009 - 09:12 PM

We haven't changed anything regarding the filters. Are the files in a directory you are downloading? The files you directly select in the remote browser are not filtered. This is however by design.

#14 cwd

cwd
  • Members
  • 6 posts

Posted 06 October 2009 - 01:55 PM

I'm uploading files from my local hard drive (local browser) onto my website (remote browser). The filter used to prevent the ".svn" folder from being uploaded, but no longer, and I can't for the life of me figure out why.

Edited by cwd, 06 October 2009 - 01:56 PM.


#15 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 06 October 2009 - 03:12 PM

I'm sorry but I could not reproduce it here.

#16 cwd

cwd
  • Members
  • 6 posts

Posted 06 October 2009 - 05:33 PM

I think the change occurred since I switched to the 64-bit version. Could that have made a difference? Also, is there a way for me to post a screenshot of my filter screen in this forum, so you can double check I've done it right?

Update - just found an alternative way to do it. View -> Toolbars -> Filter. That seems to work.

Never mind, that only makes the .svn folder disappear from view.

Edited by cwd, 06 October 2009 - 05:43 PM.


#17 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 06 October 2009 - 05:57 PM

Can you post a list of folders do you initially add to the transfer queue?

Regards,
Mat

#18 cwd

cwd
  • Members
  • 6 posts

Posted 07 October 2009 - 02:31 PM

Pretty much any folder that contains an .svn folder, or the .svn folder itself. For example, I might upload a folder called 'Drupal', that contains an '.svn' folder, amongst other folders. Problem is - the .svn folder gets uploaded as well, despite the filter settings.

#19 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 07 October 2009 - 02:49 PM

If you upload the .svn itself it will not get filtered. This is by design. However I tested it here with the 32-bit and the 64-bit version and filtering works as expected.
Does it work if you set the filters in the favorite directly instead of in the default favorite?

#20 cwd

cwd
  • Members
  • 6 posts

Posted 08 October 2009 - 02:25 PM

Ah - that's the problem. I had been uploading the files directly. I guess it makes sense to allow a direct upload if someone needs to upload that file. I don't suppose there's a way to override this setting as well? Thanks so much for your help in tracking down this issue.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users