Jump to content


Photo

Can't get to directory


  • Please log in to reply
7 replies to this topic

#1 metnix1

metnix1
  • Members
  • 4 posts

Posted 26 July 2006 - 09:23 PM

Hopefully this isn't a stupid question, but I did search for answers before posting, and came up with nothing.

My problem is simple. After logging into the FTP host I want, the directory I need is actually called "\files". However, when I put the directory in, SmartFTP automatically changes the directory to "/files" which of course ends up not found. I looked throughout the settings to turn that auto-feature off, but found nothing. Any suggestions?

Thank you very much. :unsure:

#2 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 27 July 2006 - 06:09 AM

On FTP servers Unix style path (with "/" as a delimiter) instead of Windows / DOS paths (with "\" as a delimiter) are used, so SmartFTP's conversion is correct (a good FTP server should be able to handle both, anyways). So the problem has to be with the name "files". Where do you enter that directory? In the favorite settings under "Path"? Try just using "files" with no slashes at all.

#3 metnix1

metnix1
  • Members
  • 4 posts

Posted 27 July 2006 - 03:34 PM

the actual directory is "\files\taf", if that makes a difference

I can access the directory with other FTP clients (Cute FTP), but I would really like to use Smart FTP, since I use it for almost everything else.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 27 July 2006 - 03:37 PM

Post the complete log of your FTP session.

Thank you.
Regards,
SmartFTP

#5 metnix1

metnix1
  • Members
  • 4 posts

Posted 27 July 2006 - 03:46 PM

For privacy reasons, I am taking parts of the host address out. Hope you understand

[11:42:06] SmartFTP v2.0.996.29
[11:42:06] Resolving host name "ftp.blahblahblah.com"
[11:42:06] Connecting to 1.1.1.1.1 Port: 21
[11:42:06] Connected to ftp..blahblah.com.
[11:42:06] 220 elephant FTP server (CH/1.9) ready.
[11:42:06] USER taf@blahblah.com.
[11:42:06] 331 Password required for taf@blahblah.com.
[11:42:06] PASS (hidden)
[11:42:07] 230 User taf logged in.
[11:42:07] SYST
[11:42:07] 215 UNIX Type: L8
[11:42:07] FEAT
[11:42:07] 500 'FEAT': command not understood.
[11:42:07] TYPE I
[11:42:07] 200 Type set to I.
[11:42:07] REST 0
[11:42:07] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[11:42:07] PWD
[11:42:07] 257 "/" is current directory.
[11:42:07] CWD \files\taf
[11:42:07] 250 CWD command successful.
[11:42:07] PWD
[11:42:07] 257 "/files/taf" is current directory.
[11:42:07] TYPE A
[11:42:08] 200 Type set to A.
[11:42:08] PASV
[11:42:08] 227 Entering Passive Mode (1,1,1,1,195,81)
[11:42:08] Opening data connection to 1.1.1.1 Port: 50001
[11:42:08] LIST -aL
[11:42:08] 550 -aL: No such file or directory.
[11:42:08] Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
[11:42:08] PORT 192,168,1,220,8,217
[11:42:08] 200 PORT command successful.
[11:42:08] LIST -aL
[11:42:08] 550 -aL: No such file or directory.



#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 27 July 2006 - 03:55 PM

Thanks.

You can use the command line and enter "CWD \files". The Menu -> Command -> Change Directory function automatically converts the path you enter to the server path style.

As we can see from the log your "elephant" FTP server is the cause of the problem:

[11:42:07] CWD \files\taf
[11:42:07] 250 CWD command successful.
[11:42:07] PWD
[11:42:07] 257 "/files/taf" is current directory.

Regards,
-Mat

#7 metnix1

metnix1
  • Members
  • 4 posts

Posted 27 July 2006 - 04:12 PM

Ok, you just lost me. LOL

So is the server the problem, or can I do something to work around it?

#8 Mike

Mike
  • Root Admin
  • 194 posts
  • Location:
    Ludwigshafen,Germany

Posted 27 July 2006 - 09:38 PM

There is another problem and i don't think the path is it.

[11:42:08] 227 Entering Passive Mode (1,1,1,1,195,81)
[11:42:08] Opening data connection to 1.1.1.1 Port: 50001
[11:42:08] LIST -aL
[11:42:08] 550 -aL: No such file or directory.


Goto "Tools->Settings->Transfer" and disable "Show All Files" and the "Resolve Links" if your Server is also
located on the favorites do the same there.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users