Jump to content


Photo

Cannot Delete Folder, 550 Error Message


  • Please log in to reply
10 replies to this topic

#1 Kristin

Kristin
  • Members
  • 5 posts

Posted 24 June 2006 - 10:27 AM

I've been searching around on this forum all day, and can't seem to find anything that I've not already done that will help me. I'm trying to delete a subfolder from my server and I've done everything from making files visible, to trying to change the CHMOD. But everytime I try to change it I get this:

550 Could not change perms on 'folder name': Permission denied

Changing the CHMOD worked for me previously to delete folders, but now this one is just stuck there with a big ugly red X and I'm not sure what else to do. I've even trying deleting the folders from my cpanel itself and that doesn't work either. I'm really in a bind, please help!

#2 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 26 June 2006 - 03:57 PM

It seems the server is configured in a way that does not allow you to delete this folder. Contact the server's admin for details.

#3 Kristin

Kristin
  • Members
  • 5 posts

Posted 26 June 2006 - 04:53 PM

Thanks for your reply! I contacted my host, GoDaddy.com, and the customer support over there told me that only I could remove these folders myself manually. Is it possibly my upload settings? Is there a way I can set an upload permission to private?

#4 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 26 June 2006 - 05:10 PM

It could also be that your server is configured so it only allows to delete empty folder, i.e. folders that contain no files or subfolders. In that case, you would have to delete all files / empty folders recursively and manually.

Otherwise, please post the log of a try to delete this folder.

#5 Kristin

Kristin
  • Members
  • 5 posts

Posted 26 June 2006 - 05:21 PM

I have deleted all the files that were contained in the folders, the problem is, the folder I'm having trouble deleting is a subfolder. I was running 4images and was trying to delete the folders, then re-upload them. The folders are as follows: 4images-> templates-> default. The default subfolder is the one with the problem and as many times as I've tried changing the permission from 77 (which is the permission it's stuck on) it tells me permission is denied. Here is a log of what happens when I try to delete the 'default' subfolder.

[13:17:01] RMD default
[13:17:01] 550 Can't remove directory: Directory not empty
[13:17:01] CWD /4images/templates/default
[13:17:02] 550 Can't change directory to /4images/templates/default: Permission denied
[13:17:02] PASV
[13:17:02] 227 Entering Passive Mode (68,178,211,2,153,81)
[13:17:02] Opening data connection to 68.178.211.2 Port: 39249
[13:17:02] MLSD
[13:17:03] 150 Accepted data connection
[13:17:03] 320 bytes transferred. (853 bytes/s) (375 ms)
[13:17:03] 226-Options: -a -l
[13:17:03] 226 3 matches total

It says the folder isn't empty, but I'm pretty sure that it is. Although when I try to click on the folder to check if it's empty I get this:

[13:22:01] CWD /4images/templates/default
[13:22:10] 550 Can't change directory to /4images/templates/default: Permission denied

#6 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 26 June 2006 - 07:16 PM

Try the following:
1) Connect to the site and navigate to the parent folder of the folder you want to delete.
2) Press Shift+F5 to display the Command Line toolbar.
3) At the Command Line prompt, enter
SITE CHMOD 777 <folder>
where you replace "<folder>" with the folder's name that you want to delete.
4) Now try to delete that folder.

If it still says

550 Can't remove directory: Directory not empty

double-check the folder does not contain any more (hidden) files. Two matches (which would be "." and "..") are okay, three indicate that the folder is indeed not empty.

#7 Kristin

Kristin
  • Members
  • 5 posts

Posted 27 June 2006 - 01:18 AM

I attempted to do what you said, but when I put in SITE CHMOD 777 default (which is the folder with the error I'm trying to delete) it said this:

[21:17:44] SITE CHMOD 777 default
[21:17:44] 550 Could not change perms on default: No such file or directory

:unsure: I'm so confused

#8 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 27 June 2006 - 08:53 AM

The directory seems to be deleted already, it probably only exists in the cache. Try pressing F5 to refresh the file / folder list and / or empty the cache (Tools -> Settings, Connection -> Cache).

#9 Kristin

Kristin
  • Members
  • 5 posts

Posted 28 June 2006 - 12:58 AM

This has got to be the oddest thing I've ever seen. Even after clearing the cache and restarting the program, it still sits there. It's been there for a few days. Thanks for all your help. Not sure what else I could possibly do.

#10 Underdark

Underdark
  • Members
  • 1 posts

Posted 13 July 2006 - 12:41 PM

This has got to be the oddest thing I've ever seen. Even after clearing the cache and restarting the program, it still sits there. It's been there for a few days. Thanks for all your help. Not sure what else I could possibly do.


Enter the raw ftp command: dele .htaccess in the file/folder you are having difficulty deleting. :unsure:

#11 ZAZAZAZ

ZAZAZAZ
  • Members
  • 1 posts

Posted 12 July 2011 - 09:12 PM

I spent over 24 hours trying to resolve that issue.
In my case it was jomsocial_rule.xml file that I couldn't not only delete, but to change permissions or download it.
Finally I did it.
I unzipped the original insller folders and found jomsocial_rule.xm - notice - there is no end letter "l" in it.
I renamed it correctly.
I went back to server folder and renamed the same file there to something else. Surprisingly - I could do it!
Then I was able to delete it and to replace with a new file.
Now my Akeeba Backup program is not complaining any more!
Nothing above helped me.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users