Jump to content


Photo

Reasons for ftpErrorSocket


  • Please log in to reply
3 replies to this topic

#1 2BrightSparks

2BrightSparks
  • Members
  • 44 posts
  • Gender:
    Male

Posted 29 May 2006 - 02:46 AM

Hi, we have a user who is getting an ftpErrorSocket as soon as a connection attempt is made when trying connecting to his FTP server. I've tried connecting to the same server and don't get the error, so it must be something configured on his PC causing the problem. I saw the other post about how it may be related to reusing ports, but that doesn't appear to be the problem here as it happens every time and he can connect to the FTP server using other FTP clients. He's connecting via an IP address (not hostname), but apart from that everything else is normal (no encryption, port 21, etc).

Any ideas what the problem could be? Thanks

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 29 May 2006 - 04:10 PM

Is there no error displayed in the log?

The user could also try to run SmartFTP to see if there is any error information displayed.

Regards,
-Mat

#3 2BrightSparks

2BrightSparks
  • Members
  • 44 posts
  • Gender:
    Male

Posted 30 May 2006 - 02:03 AM

Hi, the error "An invalid argument was supplied." is passed via the onStatus event just before the connect call raises an exception. Also, the LastReplyCode value is 3604531. I'll also ask them to try SmartFTP. Thanks

#4 2BrightSparks

2BrightSparks
  • Members
  • 44 posts
  • Gender:
    Male

Posted 01 June 2006 - 03:51 AM

After a reinstall using the latest version of the SmartFTP DLL the problem was resolved.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users