Jump to content


Photo

Smart FTP Freezes on opening local folder


This topic has been archived. This means that you cannot reply to this topic.
10 replies to this topic

#1 RickPowell

RickPowell
  • Members
  • 1 posts

Posted 19 April 2006 - 01:15 PM

Hi, Just a bug i came across with the latest update...

I had 995 version installed, saw there was an upgrade so i downloaded the upgrade and installed it...

When i started smart ftp it seemed to be OK, so i clicked the maximise screen icon and the program maximised and then froze.

Did an uninstall and reinstall and a restart and did same. Noticed that if local folder is not open it would connect to server ok, but as soom as i clicked the local folder icon it crashed...

I managed to figure out the problem for you though...

It seemed that in between installs, i'd installed internet explorer 7 beta 2 and it was this that caused the problem. I uninstalled ie7 and then restarted. Opened up smart ftp and it works fine...

Just thought i would let you know...

Best Wishes

Rick

currently running ok on following system spec:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2992 MHz
Total Memory : 1046604 KB
Free Memory : 512900 KB

+- SmartFTP ---------------------------
Version : 2.0.996.12
Time Stamp : 2006-04-16 12:25:06
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.8.4
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 2.0.996.12

+- System DLL -------------------------
unicows.dll : 1.0.4018.0
shell32.dll : 6.00.2900.2869 (xpsp_sp2_gdr.060316-1512)
shlwapi.dll : 6.00.2900.2823 (xpsp_sp2_gdr.060106-1520)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

#2 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts

Posted 19 April 2006 - 02:07 PM

Hi, i have installed IE 7 beta 2 and for me works fine, no hang at all.

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 19 April 2006 - 04:56 PM

Same here. No problem with the official IE7 Beta.

#4 mcgrathmg

mcgrathmg
  • Members
  • 2 posts

Posted 24 April 2006 - 11:48 PM

I have the same problem (SmartFTP freezes everytime I try to open a local folder) but I didn't install a new version of IE - all I did was install the latest build and register my copy.

Anyone help?

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 24 April 2006 - 11:52 PM

The problem might be related to one of latest patches from Microsoft. Which turned out to cause some problems under some circumstances. A new patch to fix the problem will be released on the 25. April 2006 by Microsoft.

MS Patch MS06-015
http://www.networkwo...y-security.html

Workaround
http://blogs.technet.../15/425311.aspx
Note: We have never tried this and it's absolutely no guarantee that the problem is related to this either. But the problem appeared after the patch has been released.

Very likely same problem here:
http://www.smartftp....-up-t10974.html

-Mat

#6 mcgrathmg

mcgrathmg
  • Members
  • 2 posts

Posted 25 April 2006 - 12:50 AM

I tried the workaround - no joy.

I'm not sure if it is related to the new windows update, smartftp seemed to be working fine before I upgraded it.



[...goes away... comes back]


Actually, maybe it is windows - I just tried CuteFTP and it is doing exactly the same thing...

#7 HanSooloo

HanSooloo
  • Members
  • 2 posts

Posted 05 December 2006 - 11:37 PM

I am also having the same problem. I checked the Microsoft patch, and it has been applied on my system (version 2). I also made sure that the registry key entries referred to by the above recommendations are in place.
I have IE 6 and Firefox2 installed on my system. This did not happen with the previous releases.

+- System -----------------------------
Microsoft Windows XP Professional 
Service Pack 2 (Build 2600)

CPU Speed		 : 1828 MHz
Total Memory	  : 1046892 KB
Free Memory	   :  202176 KB

+- SmartFTP ---------------------------
Version		   : 2.0.1000.2
Time Stamp		: 2006-11-22 21:35:48
Platform		  : x86

+- Application DLL --------------------
sfFTPLib.dll	  : 1.5.8.38
SmartHook.dll	 : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe	  : 2.0.1000.2

+- System DLL -------------------------
shell32.dll	   : 6.00.2900.2951 (xpsp_sp2_gdr.060713-0009)
shlwapi.dll	   : 6.00.2900.2995 (xpsp.060913-0019)
comctl32.dll	  : 6.0 (xpsp.060825-0040)
riched20.dll	  : 5.30.23.1221
schannel.dll	  : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version		   : 6.0.2900.2180

+- Winsock ----------------------------
Winsock		   : 2.2


#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 06 December 2006 - 12:57 AM

HanSooloo: What problem exactly. Please describe it in details. Thank you.

#9 HanSooloo

HanSooloo
  • Members
  • 2 posts

Posted 06 December 2006 - 01:49 PM

HanSooloo: What problem exactly. Please describe it in details. Thank you.


As soon as the Local Browser window is opened, SmartFTP freezes. A check in Task Manager's Applications tab shows 2 SmartFTP processes (although I only opened 1) that says Not Responding.

But, believe it or not, this is not happening this morning! Yesterday I followed a tip related to fixing Explorer.exe freezing problems that UnRegistered "shimgvw.dll" and "shmedia.dll" at http://www.tweakxp.c...ticle36849.aspx.

I wonder this had any bearing on SmartFTP suddenly starting to work normally again.

Thank you,
Selim

#10 trappedatuf

trappedatuf
  • Members
  • 5 posts

Posted 08 March 2007 - 06:23 AM

I am having the same EXACT problem!

I am using Windows XP SP2 and IE7 Release1 (7.0.5730.11) installed. It freezes up when I am starting the program most of the time and it has something to do with the local browser having issues.

I LOVE SmartFTP, please help me get it to work on my new computer... thanks! :-)

#11 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 March 2007 - 08:48 AM

Hello ...

Please test again with the latest version from:
http://www.smartftp....get/SFTPNSI.exe

Do you have a big .zip files on your desktop? If yes you may want to move them away to see if it helps.

Regards,
-Mat