Jump to content


Photo

no folders, no files


  • Please log in to reply
23 replies to this topic

#21 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 18 April 2006 - 12:09 AM

Borgrim: Your problem is not related to the others.

As you can see from the log only 219 bytes get transferred. You may want to disable MLSD for pureftpd.
[15:43:58] 219 bytes transferred.

Please also post the raw directory listing of the directory.

Regards,
SMartFTP

#22 Borgrim

Borgrim
  • Members
  • 3 posts

Posted 18 April 2006 - 05:40 AM

Borgrim: Your problem is not related to the others.

As you can see from the log only 219 bytes get transferred. You may want to disable MLSD for pureftpd.
[15:43:58] 219 bytes transferred.

Please also post the raw directory listing of the directory.

Regards,
SMartFTP


Thank you for the response. I did Disable the MLSD for pureftpd and still it didn't work.

Ok here is the whole story:

I wanted to update my friend's website so I asked him to give me access to the webserver to upload and download files. So he created me an seperate account and a password so I could access it. Is it possible that he didn't set the permission for me to access the content? I have feeling that I am restricted to the content of the webserver. Hope this helped.

Thanks for all the help. Below list all the information:

Here the FTP log without MLSD enabled:

[01:26:25] SmartFTP v2.0.996.12
[01:26:25] Resolving host name "x"
[01:26:26] Connecting to x
[01:26:26] Connected to x
[01:26:26] 220---------- Welcome to Pure-FTPd [TLS] ----------
[01:26:26] 220-You are user number 1 of 50 allowed.
[01:26:26] 220-Local time is now 00:26. Server port: x
[01:26:26] 220 You will be disconnected after 15 minutes of inactivity.
[01:26:26] USER x
[01:26:26] 331 User x OK. Password required
[01:26:26] PASS (hidden)
[01:26:26] 230-User x has group access to: nightsh
[01:26:26] 230 OK. Current restricted directory is /
[01:26:26] SYST
[01:26:26] 215 UNIX Type: L8
[01:26:26] FEAT
[01:26:26] 211-Extensions supported:
[01:26:26] EPRT
[01:26:26] IDLE
[01:26:26] MDTM
[01:26:26] SIZE
[01:26:26] REST STREAM
[01:26:26] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[01:26:26] MLSD
[01:26:26] ESTP
[01:26:26] PASV
[01:26:26] EPSV
[01:26:26] SPSV
[01:26:26] ESTA
[01:26:26] AUTH TLS
[01:26:26] PBSZ
[01:26:26] PROT
[01:26:26] 211 End.
[01:26:26] Detected Server Software: PureFTPd
[01:26:26] PWD
[01:26:26] 257 "/" is your current location
[01:26:26] TYPE A
[01:26:26] 200 TYPE is now ASCII
[01:26:26] PASV
[01:26:26] 227 Entering Passive Mode (x)
[01:26:26] Opening data connection to x
[01:26:26] LIST
[01:26:26] 150 Accepted data connection
[01:26:27] 119 bytes transferred. (1.87 KB/s) (62 ms)
[01:26:27] 226-Options: -a -l
[01:26:27] 226 2 matches total


The raw listing without MLSD enabled:

drwxr-xr-x	2 32168	nightsh	  4096 Apr 16 11:05 .
drwxr-xr-x	2 32168	nightsh	  4096 Apr 16 11:05 ..

The FTP log with MLSD enabled:

[01:35:00] SmartFTP v2.0.996.12
[01:35:00] Resolving host name "x"
[01:35:00] Connecting to x
[01:35:00] Connected to ftp.nightshift-guild.com.
[01:35:01] 220---------- Welcome to Pure-FTPd [TLS] ----------
[01:35:01] 220-You are user number 1 of 50 allowed.
[01:35:01] 220-Local time is now 00:34. Server port: x
[01:35:01] 220 You will be disconnected after 15 minutes of inactivity.
[01:35:01] USER x
[01:35:01] 331 User x OK. Password required
[01:35:01] PASS (hidden)
[01:35:03] 230-User x has group access to: nightsh
[01:35:03] 230 OK. Current restricted directory is /
[01:35:03] SYST
[01:35:03] 215 UNIX Type: L8
[01:35:03] FEAT
[01:35:03] 211-Extensions supported:
[01:35:03] EPRT
[01:35:03] IDLE
[01:35:03] MDTM
[01:35:03] SIZE
[01:35:03] REST STREAM
[01:35:03] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[01:35:03] MLSD
[01:35:03] ESTP
[01:35:03] PASV
[01:35:03] EPSV
[01:35:03] SPSV
[01:35:03] ESTA
[01:35:03] AUTH TLS
[01:35:03] PBSZ
[01:35:03] PROT
[01:35:03] 211 End.
[01:35:03] Detected Server Software: PureFTPd
[01:35:03] PWD
[01:35:03] 257 "/" is your current location
[01:35:03] TYPE A
[01:35:03] 200 TYPE is now ASCII
[01:35:03] PASV
[01:35:03] 227 Entering Passive Mode (x)
[01:35:03] Opening data connection to x
[01:35:03] MLSD
[01:35:04] 150 Accepted data connection
[01:35:04] 219 bytes transferred. (4.54 KB/s) (47 ms)
[01:35:04] 226-Options: -a -l
[01:35:04] 226 2 matches total



The raw listing with MLSD enabled:

type=cdir;sizd=4096;modify=20060416160548;UNIX.mode=0755;UNIX.uid=32168;UNIX.gid=32169;unique=301g32c11e; .
type=pdir;sizd=4096;modify=20060416160548;UNIX.mode=0755;UNIX.uid=32168;UNIX.gid=32169;unique=301g32c11e; ..


#23 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 18 April 2006 - 06:55 AM

Hello ..

The directory is empty.

Regards,
SmartFTP

#24 Borgrim

Borgrim
  • Members
  • 3 posts

Posted 18 April 2006 - 01:43 PM

Hello ..

The directory is empty.

Regards,
SmartFTP


Sorry about all the fuss and taking your time. I was misinformed. Thanks for quick replies and for good customer service.

Thanks,
Borgrim




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users