Jump to content


Photo

no folders, no files


  • Please log in to reply
23 replies to this topic

#1 henry

henry
  • Members
  • 4 posts

Posted 19 March 2006 - 07:42 PM

Sorry for another posting with this title, but I searched now for several hours and none of the solutions I found worked for me.

If I connect to a server of a friend, no folders or files are shown. I can manually change into one directory, but still no files are shown. I can uplaod files to the server, but they are not shown in SmartFTP.

Changing the 'directory listing options' in settings - transfer doesn't show any effect, it makes no difference if none or any combination of them are enabled or disabled.

I reinstalled SmartFTP, without a change.

I have no problems by connecting with a browser or an older version of WS-FTP.

Here is my raw listing:
drw-r--r--  2 0		0		4096  Mar  7 18:27 Share
-rw-r--r--  1 0		0		0  Feb 28 13:19 time_status
drw-r--r--  3 0		0		4096  Feb 25 04:03 HTML
drw-r--r--  2 0		0		4096  Feb 28 13:18 DATA
drw-r--r--  2 0		0		4096  Feb 23 15:08 Scripts
drw-r--r--  3 0		0		4096  Mar  1 13:10 toddi
and my log:

[20:37:10] SmartFTP v2.0.995.16
[20:37:11] Resolving host name "xxxxx.net"
[20:37:11] Connecting to xxx.xxx.xxx.xxx Port: 21
[20:37:11] Connected to xxxxx.net.
[20:37:11] 220 SERVER FTP server ready.
[20:37:11] USER xxxxx
[20:37:11] 331 Password required for xxxxx.
[20:37:11] PASS (hidden)
[20:37:11] 230 User xxxxx logged in.
[20:37:11] SYST
[20:37:11] 215 UNIX Type: L8
[20:37:11] FEAT
[20:37:11] 500 'FEAT': command not understood.
[20:37:11] TYPE I
[20:37:11] 200 Type set to I.
[20:37:11] REST 0
[20:37:11] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[20:37:11] PWD
[20:37:11] 257 "/" is current directory.
[20:37:15] TYPE A
[20:37:15] 200 Type set to A.
[20:37:15] PASV
[20:37:15] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,4,129)
[20:37:15] Opening data connection to xxx.xxx.xxx.xxx Port: 1153
[20:37:15] LIST
[20:37:15] 150 Opening ASCII mode data connection for 'file list'.
[20:37:15] 524 bytes transferred. (17,0 KB/s) (30 ms)
[20:37:15] 226 Transfer complete.


Any ideas?

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 20 March 2006 - 12:30 PM

Please test it with the latest version from:
http://www.smartftp....et/SFTPBeta.exe

Do you know by any chance what FTP server software is running on the server?

Thanks
-Mat

#3 henry

henry
  • Members
  • 4 posts

Posted 20 March 2006 - 08:09 PM

Jep, with the version from the link it's working, also with the 'directory listing options' enabled.

And no, I don't know what server software is running on the server. It's some kind of a Linux OS, but that's all I can say. Why are you asking, could there be some incompatibilties with any server software or what?

And what are the differences between the beta version and the final? Can I use the beta without any risks or are there some security or other problems?

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 20 March 2006 - 10:45 PM

The version available now is final.

#5 kthardin

kthardin
  • Members
  • 3 posts

Posted 22 March 2006 - 05:26 AM

I have a similar problem. I had aquired an old alcatel switch from ebay and was attempting to update its operating system. While I could transfer files to it, I couldn't see any files or folders inside the switch. WS_FTP has no such problems.

As henry did before me, I removed all directory listing options with no effect. I even used the beta version posted with no change.

Any ideas?

#6 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 22 March 2006 - 06:04 AM

Post the transfer log and the raw directory listing as henry did.

Thanks
-Mat

#7 mackal

mackal
  • Members
  • 2 posts

Posted 22 March 2006 - 04:03 PM

I'm having the same problem here, just started an hour ago. I've been transferring to/from this same host for weeks, when today out of the blue, mid-transfer SmartFTP stopped working with that host, although it works with other hosts still. I tried the remote site with Filezilla and it works, so it's not the remote's fault. Here's the SmartFTP log:

[11:45:05] SmartFTP v2.0.994.8
[10:45:05] Resolving host name "192.168.1.10"
[10:45:05] Connecting to 192.168.1.10 Port: 21
[10:45:05] Connected to 192.168.1.10.
[10:45:05] 220 localhost FTP server (Version 6.4/OpenBSD/Linux-ftpd-0.17) ready.
[10:45:05] USER mac
[10:45:05] 331 Password required for mac.
[10:45:05] PASS (hidden)
[10:45:05] 230- Linux shodan 2.6.15-1-686 #2 Thu Feb 2 18:29:01 UTC 2006 i686 GNU/Linux
[10:45:05] 230-
[10:45:05] 230- The programs included with the Debian GNU/Linux system are free software;
[10:45:05] 230- the exact distribution terms for each program are described in the
[10:45:05] 230- individual files in /usr/share/doc/*/copyright.
[10:45:05] 230-
[10:45:05] 230- Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
[10:45:05] 230- permitted by applicable law.
[10:45:05] 230 User mac logged in.
[10:45:05] SYST
[10:45:05] 215 UNIX Type: L8 (Linux)
[10:45:05] TYPE I
[10:45:05] 200 Type set to I.
[10:45:05] REST 0
[10:45:05] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[10:45:05] PWD
[10:45:05] 257 "/home/mac" is current directory.
[10:45:06] CWD /
[10:45:06] 250 CWD command successful.
[10:45:06] PWD
[10:45:06] 257 "/" is current directory.
[10:45:06] TYPE A
[10:45:06] 200 Type set to A.
[10:45:06] PASV
[10:45:06] 227 Entering Passive Mode (192,168,1,10,177,119)
[10:45:06] Opening data connection to 192.168.1.10 Port: 45431
[10:45:06] LIST -aL
[10:45:06] 150 Opening ASCII mode data connection for '/bin/ls'.
[10:45:06] 2018 bytes transferred. (N/A/s) (0 ms)
[10:45:06] 226 Transfer complete.


It doesn't matter which directory on this server I change into, the effect is always the same (i.e., empty). Here for example is the raw listing for "/mnt" on the remote host, which also does not showup within SmartFTP:

total 20
drwxr-xr-x   5 root root 4096 2005-12-17 15:02 .
drwxr-xr-x  28 root root 4096 2006-02-10 13:06 ..
drwxrwxrwx   2 root root 4096 2004-01-09 20:34 pix
drwxr-xr-x   2 root root 4096 2004-02-01 19:49 tmp
drwxr-xr-x   2 root root 4096 2005-12-17 15:02 usb


#8 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 22 March 2006 - 07:40 PM

Aha. Interesting that all these FTP servers running under linux always come up with a slightly different listing format instead of supporting MLSD. I will see that the next version will support the "new" listing format.

#9 kthardin

kthardin
  • Members
  • 3 posts

Posted 24 March 2006 - 03:55 AM

Here's the raw listing of the /flash/working directory:

Listing Directory /flash/working:

drw 512 Mar 23 14:39 ./
drw 512 Mar 23 14:39 ../
-rw 9536 Mar 23 14:39 boot.cfg
-rw 282432 Sep 13 2005 Hadvrout.img
-rw 3676422 Sep 13 2005 Hbase.img
-rw 114588 Sep 13 2005 Hdiag.img
-rw 1371910 Sep 13 2005 Heni.img
-rw 827135 Sep 13 2005 Hl2eth.img
-rw 895824 Sep 13 2005 Hos.img
-rw 295537 Sep 13 2005 Hqos.img
-rw 6693 Sep 13 2005 Hrelease.img
-rw 518313 Sep 13 2005 Hrout.img
-rw 130094 Sep 13 2005 Hsecu.img
-rw 1341232 Sep 13 2005 Hweb.img
-rw 72714 Sep 13 2005 Hwebadvrout.img
-rw 279671 Sep 13 2005 Hwebl2eth.img
-rw 247399 Sep 13 2005 Hwebqos.img
-rw 158585 Sep 13 2005 Hwebrout.img
-rw 210200 Sep 13 2005 Hwebsecu.img
-rw 1054 Sep 13 2005 software.lsm
-rw 105613 Sep 13 2005 certs.pem

4634624 bytes free


This is the SmartFTP log:

[15:19:25] Connecting to 192.168.1.1 Port: 21
[15:19:25] Connected to 192.168.1.1.
[15:19:25] 220 FTP server ready
[15:19:25] USER admin
[15:19:25] 331 Password required
[15:19:25] PASS (hidden)
[15:19:26] 230-
[15:19:26]
[15:19:26] Welcome to the Alcatel OmniSwitch 6000
[15:19:26] Software Version 5.1.5.127.R04 Service Release, March 28, 2005.
[15:19:26] Copyright©, 1994-2003 Alcatel Internetworking, Inc. All Rights reserved.
[15:19:26] OmniSwitch™ is a trademark of Alcatel Internetworking, Inc. registered
[15:19:26] in the United States Patent and Trademark Office.
[15:19:26]
[15:19:26] 230
[15:19:26] SYST
[15:19:26] 500 Command not recognized
[15:19:26] FEAT
[15:19:26] 500 Command not recognized
[15:19:26] TYPE I
[15:19:26] 200 Type set to I, binary mode
[15:19:26] REST 0
[15:19:26] 500 Command not recognized
[15:19:26] PWD
[15:19:26] 257 Current directory is "/flash/working"



#10 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 March 2006 - 07:58 AM

We are not planning to support the Alcatel OmniSwitch 6000 device unless you can give us a good reason.

Regards,
-Mat

#11 kthardin

kthardin
  • Members
  • 3 posts

Posted 24 March 2006 - 09:33 AM

We are not planning to support the Alcatel OmniSwitch 6000 device unless you can give us a good reason.

Regards,
-Mat


I was just kinda curious why this product wasn't able to list files in the directories of this switch and WS FTP was able to do so.

It's a simple unix command when I use command line ftp; the ol 'ls' will give me a straight text display of it.

Of course, with a response of this nature, I'm not sure that SmartFTP will be useful for me in the future concerning other similar devices I may aquire. Though I note, you DID tell me to post my logs when I already identified the device in question...though perhaps not the exact model number; I'll be more specific in the future.

This is good to know. My search goes on then.

#12 GreyHound

GreyHound
  • Members
  • 12 posts

Posted 26 March 2006 - 02:01 PM

I had the same problem and the new version. (*.19) solved it.
I think i was using *.12 before.

#13 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 27 March 2006 - 11:57 AM

mackal: The latest beta version available from http://www.smartftp....get/SFTPNSI.exe should now work with your FTP server. Please give it a try.

Thanks
-Mat

#14 mackal

mackal
  • Members
  • 2 posts

Posted 27 March 2006 - 04:36 PM

mackal: The latest beta version available from http://www.smartftp....get/SFTPNSI.exe should now work with your FTP server. Please give it a try.

Thanks
-Mat


Before even installing this version, I decided to give the currently installed one one last try (so that I could confirm that indeed any improvement was to the update). It turns out that today I'm once again able to access that remote host with the regular SmartFTP 2.0. I haven't retried doing this since my posts above.

As I understand it you were thinking it has something to do with the output formatting on the remote, so here's the Raw listing of the same directory I listed above, this time for when SmartFTP 2.0 (regular, non-patch/experimental) *can* access the system.

total 20
drwxr-xr-x 5 root root 4096 Dec 17 15:02 .
drwxr-xr-x 28 root root 4096 Feb 10 13:06 ..
drwxrwxrwx 2 root root 4096 Jan 9 2004 pix
drwxr-xr-x 2 root root 4096 Feb 1 2004 tmp
drwxr-xr-x 2 root root 4096 Dec 17 15:02 usb


Interesting, so the date format changed. Very strange, nothing has happened that I can think of that would have caused the remote to switch date formats... as I pointed out earlier, the breakdown occurred mid-transfer, as one item on the global queue finished downloading, and before the next one started. The weird thing is that nothing was happening to the remote system that I can think of as doing this date change... the two systems in question were sitting beside each other: local=my laptop, remote=my desktop, 1 foot to the right. :unsure: There was no remote reboot, no system upgrade occurring, etc.

So, the "Raw listing" is exactly the output an FTP client gets from the server? I might poke around Debian's lists see why this happened and file a bug if necessary with that package...

Alas, as it's doing fine now, I can't comment on the suitability of the patched version you pointed out... :rolleyes:

#15 berserk

berserk
  • Members
  • 2 posts

Posted 06 April 2006 - 05:00 PM

Hi everybody,

I read the messages about directory listing not visible from some FTP servers: I have installed the latest version of SmartFTP (2.0.996) but I still can't see the directory listing.

Here you can see the messages from the log window:

[18:43:39] 220--------------------------------------------------------------------------------
[18:43:40] 220-This is the "Banner" message for the Mac OS X Server's FTP server process.
[18:43:40] 220-
[18:43:40] 220- FTP clients will receive this message immediately
[18:43:40] 220- before being prompted for a name and password.
[18:43:40] 220-
[18:43:40] 220-PLEASE NOTE:
[18:43:40] 220-
[18:43:40] 220- Some FTP clients may exhibit problems if you make this file too long.
[18:43:40] 220-
[18:43:40] 220--------------------------------------------------------------------------------
[18:43:40] 220-
[18:43:40] 220 romanista.sbrize.it FTP server (Version: Mac OS X Server 10.3.2 - +GSSAPI) ready.
[18:43:40] USER romanista
[18:43:40] 331 Password required for romanista.
[18:43:40] PASS (hidden)
[18:43:40] 230--------------------------------------------------------------------------------
[18:43:40] 230-This is the "Welcome" message for the Mac OS X Server's FTP server process.
[18:43:40] 230-
[18:43:40] 230-FTP clients will receive this message right after a successful log in.
[18:43:40] 230-
[18:43:40] 230--------------------------------------------------------------------------------
[18:43:40] 230-
[18:43:40] 230 User romanista logged in.
[18:43:40] SYST
[18:43:40] 215 UNIX Type: L8 Version: BSD-199506
[18:43:40] FEAT
[18:43:41] 211-Supported features:
[18:43:41] REST STREAM
[18:43:41] ADAT
[18:43:41] AUTH
[18:43:41] CCC
[18:43:41] CONF
[18:43:41] ENC
[18:43:41] MIC
[18:43:41] PBSZ
[18:43:41] PROT
[18:43:41] MDTM
[18:43:41] SIZE
[18:43:41] 211 End
[18:43:41] PWD
[18:43:41] 257 "/Users/romanista" is current directory.
[18:43:41] CWD /Users/romanista/sites
[18:43:41] 250 CWD command successful.
[18:43:41] PWD
[18:43:41] 257 "/Users/romanista/sites" is current directory.
[18:43:41] TYPE A
[18:43:41] 200 Type set to A.
[18:43:41] PASV
[18:43:41] 227 Entering Passive Mode (213,203,143,149,15,205)
[18:43:42] Opening data connection to 213.203.143.149 Port: 4045
[18:43:42] LIST -aL
[18:43:42] 150 Opening ASCII mode data connection for directory listing.
[18:43:42] 39 bytes transferred. (278 bytes/s) (140 ms)
[18:43:42] 226 Transfer complete.

And here's the result using FTP from a DOS command window:
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for directory listing.
total 4920
drwxr-xr-x	 3 romanist  staff		102 Dec 10 17:34 BACKUPS
drwxr-xr-x	17 romanist  100		  578 Oct  3  2004 FCKeditor
drwxr-xr-x	 3 romanist  staff		102 Apr  6 10:26 GONJPG
drwxr-xr-x	 2 romanist  staff		 68 Apr  6 10:23 GONPDF
drwxr-xr-x	 3 romanist  staff		102 Apr  5 09:33 GiornaleOnLine
drwxr-xr-x	47 romanist  100		 1598 Mar 16  2005 RRroma_tutti_tempi_
-rw-r--r--	 1 romanist  100		 6434 Aug 28  2004 TurboTime.class
-rw-r--r--	 1 romanist  100		 1645 Jan 27  2005 WWlogin.php
drwxr-xr-x	 2 romanist  100		   68 Mar  2  2005 XYIZNWSK
drwxr-xr-x	 6 romanist  staff		204 Mar 31 18:31 a_mondezza
-rw-r--r--	 1 romanist  100		 9618 Jan 27  2005 a_test_index.php
-rw-r--r--	 1 romanist  100		29915 Jan 21  2005 abbonamenti.php
drwxr-xr-x	71 romanist  100		 2414 Dec  5 09:17 admin
-rw-r--r--	 1 romanist  staff	  39483 Aug  2  2005 agenda.swf
-rw-r--r--	 1 romanist  staff	  36150 Aug  2  2005 agenda.swf2
-rw-r--r--	 1 romanist  staff	  35282 Aug 29  2005 agenda2.swf
-rw-r--r--	 1 romanist  staff	   1184 Jul  4  2005 alice.htm
-rw-r--r--	 1 romanist  staff	   1025 Sep  1  2005 alice.php
drwxr-xr-x	 3 romanist  staff		102 Dec 24 11:55 asta
drwxr-xr-x	52 romanist  100		 1768 Mar  1 17:58 banner
-rw-r--r--	 1 romanist  100		17234 Sep 28  2004 banner.swf
-rw-r--r--	 1 romanist  100		10356 Feb 22  2005 banner1.swf
-rw-r--r--	 1 romanist  staff	   1250 Jul  4  2005 banner1_sx.php
-rw-r--r--	 1 romanist  staff	  13533 Aug  2  2005 banner_sms.swf
drwxr-xr-x	 5 romanist  100		  170 Mar  7  2005 bannerzeman
-rw-r--r--	 1 romanist  staff	  17945 May  9  2005 cards_banner.swf
-rw-r--r--	 1 romanist  staff	  23029 Mar 30 12:51 carrello_rstore.php
Is there any reason, maybe related to the supported features?

Thank you so much

#16 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 06 April 2006 - 05:33 PM

berserk: The problem is not with the listing decoder. It's with the listing options -aL.

[18:43:42] LIST -aL
[18:43:42] 150 Opening ASCII mode data connection for directory listing.
[18:43:42] 39 bytes transferred. (278 bytes/s) (140 ms)

As you can see only 39 bytes are transferred. Go to the Settings->Transfer and remove the -a (Show all files) and -L (Resolve Links) switch from the "Directory Listing Options".

Please consider buying a license. Thank you.

Regards,
SmartFTP

#17 berserk

berserk
  • Members
  • 2 posts

Posted 07 April 2006 - 08:07 AM

berserk: The problem is not with the listing decoder. It's with the listing options -aL.

[18:43:42] LIST -aL
[18:43:42] 150 Opening ASCII mode data connection for directory listing.
[18:43:42] 39 bytes transferred. (278 bytes/s) (140 ms)

As you can see only 39 bytes are transferred. Go to the Settings->Transfer and remove the -a (Show all files) and -L (Resolve Links) switch from the "Directory Listing Options".

Please consider buying a license. Thank you.

Regards,
SmartFTP


Thank you for your quick answer.

Regards,

Berserk

#18 abenaki

abenaki
  • Members
  • 1 posts

Posted 13 April 2006 - 02:28 AM

I had the same Problem; could not see files or folders on the server, though could see all with: AceFTP3, CoreFTP, FileZilla, FreeFTP, FTP Voyager, JFTP, and WS_FTP, but could not see any listing with SmartFTP. What could be the problem? I get everything with raw listing, but nothing in the browser window.
Here are the raw listing:
drwx------  1 user	group		 2048 Apr 12 09:08 .
drwx------  1 user	group		 2048 Apr  1 16:38 ..
-rwx------  1 user	group		 1596 May 28  2001 key.id
-rwx------  1 user	group		   15 Jan 17  2005 program.id
-rwx------  1 user	group		   15 May 28  2001 release.dir
drwx------  1 user	group		 2048 Jan 20  2005 syspar
-rwx------  1 user	group			0 Apr  1 16:37 ctrlused
-rwx------  1 user	group	 10490276 Apr  1 15:45 image.bin
-rwx------  1 user	group		 5205 May 28  2001 katakan.tpu
-rwx------  1 user	group		 9176 May 28  2001 startup.cmd
-rwx------  1 user	group		  597 Jan 17  2005 user.sys
-rwx------  1 user	group		 1751 Jan 17  2005 base_mt.sys
-rwx------  1 user	group		  142 May 28  2001 opt_l0.cmd
-rwx------  1 user	group			0 Apr 12 09:08 pgmcpl1.log
-rwx------  1 user	group		   18 Apr  1 16:38 SYSPAR.LOG
drwx------  1 user	group		 2048 Jan 20  2005 KRAFT32
-rwx------  1 user	group		 4946 Jan 17  2005 CommPLC.mod
-rwx------  1 user	group		21615 Jan 20  2005 MultiIO.mod
-rwx------  1 user	group			0 Jan 20  2005 pgmcpl2.log
drwx------  1 user	group		 2048 Jun 30  2005 Pattern
-rwx------  1 user	group			0 Apr 12 03:11 pgmcpl3.log
-rwx------  1 user	group			0 Jan 20  2005 pgmcpl4.log
-rwx------  1 user	group		67054 Jan 20  2005 ManMode.mod
-rwx------  1 user	group	   280874 Jan 20  2005 AxWare.prg
-rwx------  1 user	group		 5873 Jan 20  2005 DispTP.sys
and the log;
[09:00:17] SmartFTP v2.0.996.10
[09:00:17] Resolving host name "192.168.125.1"
[09:00:17] Connecting to 192.168.125.1 Port: 21
[09:00:17] Connected to 192.168.125.1.
[09:00:17] 220 VxWorks FTP server (VxWorks 5.3.1) ready.
[09:00:17] USER (hidden)
[09:00:17] 331 Password required
[09:00:17] PASS (hidden)
[09:00:17] 230 User logged in
[09:00:17] SYST
[09:00:17] 215 UNIX Type: L8 Version: VxWorks
[09:00:17] FEAT
[09:00:17] 500 Command not recognized
[09:00:17] TYPE I
[09:00:17] 200 Type set to I, binary mode
[09:00:17] REST 0
[09:00:17] 500 Command not recognized
[09:00:17] PWD
[09:00:17] 257 Current directory is "/hd0a/64Z-20070"
[09:00:17] CWD 192.168.125.81
[09:00:17] 501 Directory non existent or syntax error
[09:00:57] CWD /hd0a/64-20070
[09:00:58] 501 Directory non existent or syntax error
[09:01:00] CWD /hd0a/64-20070
[09:01:00] 501 Directory non existent or syntax error
[09:01:34] TYPE A
[09:01:34] 200 Type set to A, ASCII mode
[09:01:34] PASV
[09:01:34] 227 Entering Passive Mode (192,168,125,1,4,9)
[09:01:34] Opening data connection to 192.168.125.1 Port: 1033
[09:01:34] LIST
[09:01:34] 150 Opening ASCII mode data connection
[09:01:35] 226 Transfer complete
[09:01:35] 1625 bytes transferred. (1.84 KB/s) (861 ms)
[09:01:43] PASV
[09:01:43] 227 Entering Passive Mode (192,168,125,1,4,10)
[09:01:43] Opening data connection to 192.168.125.1 Port: 1034
[09:01:43] LIST
[09:01:43] 150 Opening ASCII mode data connection
[09:01:44] 226 Transfer complete
[09:01:44] 1625 bytes transferred. (2.16 KB/s) (731 ms)
[09:02:35] NOOP
[09:02:35] 200 NOOP -- did nothing as requested!
[09:03:25] NOOP
[09:03:25] 200 NOOP -- did nothing as requested!
[09:03:50] CWD /
[09:03:50] 250 Changed directory to "/"
[09:03:50] PWD
[09:03:50] 257 Current directory is "/"
[09:03:50] PASV
[09:03:50] 227 Entering Passive Mode (192,168,125,1,4,11)
[09:03:50] Opening data connection to 192.168.125.1 Port: 1035
[09:03:50] LIST
[09:03:50] 150 Opening ASCII mode data connection
[09:03:51] 578 bytes transferred. (3.52 KB/s) (160 ms)
[09:03:51] 226 Transfer complete
[09:04:44] CWD /hd0a/64Z-20070
[09:04:44] 250 Changed directory to "/hd0a/64Z-20070"
[09:04:44] PWD
[09:04:44] 257 Current directory is "/hd0a/64Z-20070"
[09:04:44] PASV
[09:04:44] 227 Entering Passive Mode (192,168,125,1,4,12)
[09:04:44] Opening data connection to 192.168.125.1 Port: 1036
[09:04:44] LIST
[09:04:44] 150 Opening ASCII mode data connection
[09:04:45] 226 Transfer complete
[09:04:45] 1625 bytes transferred. (3.44 KB/s) (461 ms)


would appreciate any help, I like your soft, but would like it more if it would work

#19 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 April 2006 - 05:14 AM

Hello ..

Thanks for your posting. Please try it with the new version .11
http://www.smartftp....et/SFTPBeta.exe

VxWorks changes its software with every release. Now it suddenly behaves like a unix FTP server. This change has been addressed in the latest version of SmartFTP.

Regards,
-Mat

#20 Borgrim

Borgrim
  • Members
  • 3 posts

Posted 17 April 2006 - 07:46 PM

Hi,

I have the same problem too. I downloaded the lastest SmartFTP and read the whole thread and changed the setting accordingly, but I still can't get the file or the folders to show up. Any help on this?

Thank you

[15:43:57] SmartFTP v2.0.996.12
[15:43:57] Resolving host name "xxxxxx"
[15:43:57] Connecting to xxxx Port: xxx
[15:43:57] Connected to xxxxxxx.
[15:43:57] 220---------- Welcome to Pure-FTPd [TLS] ----------
[15:43:57] 220-You are user number 2 of 50 allowed.
[15:43:57] 220-Local time is now 14:43. Server port: xxx.
[15:43:57] 220 You will be disconnected after 15 minutes of inactivity.
[15:43:57] USER xxxxxxxxx
[15:43:57] 331 User xxxxxx OK. Password required
[15:43:57] PASS (hidden)
[15:43:58] 230-User xxxxx has group access to: xxx
[15:43:58] 230 OK. Current restricted directory is /
[15:43:58] SYST
[15:43:58] 215 UNIX Type: L8
[15:43:58] FEAT
[15:43:58] 211-Extensions supported:
[15:43:58] EPRT
[15:43:58] IDLE
[15:43:58] MDTM
[15:43:58] SIZE
[15:43:58] REST STREAM
[15:43:58] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[15:43:58] MLSD
[15:43:58] ESTP
[15:43:58] PASV
[15:43:58] EPSV
[15:43:58] SPSV
[15:43:58] ESTA
[15:43:58] AUTH TLS
[15:43:58] PBSZ
[15:43:58] PROT
[15:43:58] 211 End.
[15:43:58] Detected Server Software: PureFTPd
[15:43:58] PWD
[15:43:58] 257 "/" is your current location
[15:43:58] TYPE A
[15:43:58] 200 TYPE is now ASCII
[15:43:58] PASV
[15:43:58] 227 Entering Passive Mode (xxx)
[15:43:58] Opening data connection to xxxxx
[15:43:58] MLSD
[15:43:58] 150 Accepted data connection
[15:43:58] 219 bytes transferred. (4.54 KB/s) (47 ms)
[15:43:58] 226-Options: -a -l
[15:43:58] 226 2 matches total






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users