Jump to content


Photo

Connection problems via proxy (Webwasher)


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 bluemoon

bluemoon
  • Members
  • 6 posts

Posted 27 January 2006 - 10:28 AM

Hi,

I posted the following question already in the german forum, now I hope someopne can hep me here:

Up to version 1.1.985 we were able to use SmartFTP with our Proxy (Webwasher):

SmartFTP v1.1.985.6
Resolving host name 172.20.8.63...
Resolving host name ftp.nai.com...
Connecting to Proxy (172.20.8.63) -> IP: 172.20.8.63 PORT: 21
Connected to Proxy (172.20.8.63) -> Time = 0ms
Socket connected waiting for login sequence.
220 Webwasher FTP Proxy 5.3.0 build 1953
USER DOMAIN\USER
331 User name okay, need password.
PASS (hidden)
230-Webwasher Authentication successful.
230 Use SITE command or another USER/PASS sequence.
USER anonymous@ftp.nai.com
331 User name okay, need password.
PASS (hidden)
230-You are connected to ftp.nai.com.Your use is subject to the terms and
230-conditions in Legal.TXT and Usage.TXT files
230 Anonymous user logged in.

Since then (and also the V2) SmartFTP does not connect to any remote server (same settings in preferences!):

SmartFTP v2.0.993.13
Resolving host name "172.20.8.63"
Connecting to 172.20.8.63 Port: 21
Connected to ftp.nai.com.
220 Webwasher FTP Proxy 5.3.0 build 1953
USER anonymous@ftp.nai.com
530 Gateway authentication needed. Syntax: LocalUser@RemoteUser@Host
Cannot login waiting to retry (30s)...

Where is my mistake? What's the problem?

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 January 2006 - 12:23 PM

Check your favorite item proxy settings.
-Mat

#3 bluemoon

bluemoon
  • Members
  • 6 posts

Posted 27 January 2006 - 01:29 PM

Thanks for your reply. But I made a fresh install. Also with a completely fresh windows installation we receive same behaviour :unsure:

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 January 2006 - 01:41 PM

If possible please post a screenshot of the Settings->Connection->Proxy dialog.

Thanks
-Mat

#5 bluemoon

bluemoon
  • Members
  • 6 posts

Posted 27 January 2006 - 01:59 PM

Here you go:

Posted Image

The user is typed like DOMAIN\USER.

I made a TCP Trace and the very first commando I see is "USER user@remotehost". It seems SmartFTP ignores the checkbox "login to firewall/proxy".

#6 bluemoon

bluemoon
  • Members
  • 6 posts

Posted 27 January 2006 - 03:30 PM

It was a simple bug in SmartFTP.

Thanks for the fast troubleshooting.