Jump to content


Photo

Unable To List MLSD


This topic has been archived. This means that you cannot reply to this topic.
18 replies to this topic

#1 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 16 April 2008 - 05:00 AM

Hi,

Im trying to connect to a server, and im unable to do a list (with MLSD on or off). I have tried the same setup in FTPRush and it works no problems, same as FlashFXP which works as well.

[14:17:55] PASV
[14:17:56] 227 Entering Passive Mode (172,16,14,223,17,110)
[14:17:56] Opening data connection to 172.16.14.223 Port: 4462
[14:17:56] MLSD
[14:18:17] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[14:19:17] Timeout (60s).

Here is MLSD and compression off

[14:57:29] 230 User logged in, proceed.
[14:57:29] SYST
[14:57:30] 215 UNIX Type: L8
[14:57:30] Detected Server Type: UNIX
[14:57:30] FEAT
[14:57:31] 211-Extension supported
[14:57:32] CLNT
[14:57:32] MDTM
[14:57:32] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[14:57:32] SIZE
[14:57:32] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[14:57:32] REST STREAM
[14:57:32] XCRC filename;start;end
[14:57:32] MODE Z
[14:57:32] MLST Type*;Size*;Create;Modify*;Win32.ea*;
[14:57:32] 211 End
[14:57:32] Detected Server Software: Serv-U 5.x/6.x
[14:57:32] CLNT SmartFTP 2.5.1008
[14:57:33] 200 Noted.
[14:57:33] PWD
[14:57:34] 257 "/" is current directory.
[14:57:34] TYPE A
[14:57:35] 200 Type set to A.
[14:57:35] PASV
[14:57:36] 227 Entering Passive Mode (172,16,14,223,19,86)
[14:57:36] Opening data connection to 172.16.14.223 Port: 4950
[14:57:36] LIST -aLT
[14:57:57] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.



I have tried multiple PC's and even the latest beta of 3.0

This is only happening on one server I connect to. What worries me is why FlashFXP and RushFTP work (both MLSD or List)

Thanks

Hugo

#2 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 16 April 2008 - 07:08 AM

Try active mode (Port).

Regards,
Mat

#3 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 16 April 2008 - 11:15 PM

Sorry no go. Thought I did try that before (I have tried so many things)

Here is the trace:

[09:12:02] 230 User logged in, proceed.
[09:12:02] SYST
[09:12:03] 215 UNIX Type: L8
[09:12:03] Detected Server Type: UNIX
[09:12:03] TYPE I
[09:12:03] 200 Type set to I.
[09:12:03] REST 0
[09:12:03] 350 Restarting at 0. Send STORE or RETRIEVE.
[09:12:03] PWD
[09:12:04] 257 "/" is current directory.
[09:12:04] TYPE A
[09:12:04] 200 Type set to A.
[09:12:04] PORT 10,5,5,100,5,64
[09:12:05] 200 PORT Command successful.
[09:12:05] LIST -aL
[09:12:05] 150 Opening ASCII mode data connection for /bin/ls.
[09:12:26] 426 Data connection closed, transfer aborted.
[09:12:26] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".
[09:12:26] PASV
[09:12:26] 227 Entering Passive Mode (172,16,14,223,12,55)
[09:12:26] Opening data connection to 172.16.14.223 Port: 3127
[09:12:26] LIST -aL
[09:12:47] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


HERE IS FLASHFXP

[09:29:20] [R] 230 User logged in, proceed.
[09:29:20] [R] SYST
[09:29:20] [R] 215 UNIX Type: L8
[09:29:20] [R] FEAT
[09:29:21] [R] 211-Extension supported
[09:29:21] [R] CLNT
[09:29:21] [R] MDTM
[09:29:21] [R] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[09:29:21] [R] SIZE
[09:29:21] [R] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[09:29:21] [R] REST STREAM
[09:29:21] [R] XCRC filename;start;end
[09:29:21] [R] MODE Z
[09:29:21] [R] MLST Type*;Size*;Create;Modify*;Win32.ea*;
[09:29:21] [R] 211 End
[09:29:22] [R] CLNT FlashFXP 3.4.0.1145
[09:29:22] [R] 200 Noted.
[09:29:22] [R] CWD /download
[09:29:22] [R] 550 /download: No such file or directory.
[09:29:22] [R] PWD
[09:29:23] [R] 257 "/" is current directory.
[09:29:23] [R] TYPE A
[09:29:23] [R] 200 Type set to A.
[09:29:23] [R] MODE Z
[09:29:23] [R] 200 MODE Z ok.
[09:29:23] [R] PASV
[09:29:24] [R] 227 Entering Passive Mode (172,16,14,223,12,208)
[09:29:24] [R] Opening data connection IP: 58.62.223.223 PORT: 3280
[09:29:24] [R] LIST -al
[09:29:24] [R] 150 Opening ASCII mode data connection for /bin/ls.
[09:29:25] [R] 226 Transfer complete.
[09:29:25] [R] List Complete: 584 bytes in 2.79 seconds (0.2 KB/s)

Hugo

Edited by hugo.georg, 16 April 2008 - 11:30 PM.


#4 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 12:59 AM

Try to remove the -T switch from directory listing options:
http://www.smartftp....tions-f137.html

Regards,
Mat

#5 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 01:58 AM

Nope, no go. I did try this before, but here is the capture.

[11:31:32] SYST
[11:31:33] 215 UNIX Type: L8
[11:31:33] Detected Server Type: UNIX
[11:31:33] FEAT
[11:31:34] 211-Extension supported
[11:31:35] CLNT
[11:31:35] MDTM
[11:31:35] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[11:31:35] SIZE
[11:31:35] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[11:31:35] REST STREAM
[11:31:35] XCRC filename;start;end
[11:31:35] MODE Z
[11:31:35] MLST Type*;Size*;Create;Modify*;Win32.ea*;
[11:31:35] 211 End
[11:31:35] Detected Server Software: Serv-U 5.x/6.x
[11:31:35] CLNT SmartFTP 2.5.1008
[11:31:36] 200 Noted.
[11:31:36] PWD
[11:31:37] 257 "/" is current directory.
[11:31:37] TYPE A
[11:31:38] 200 Type set to A.
[11:31:38] PASV
[11:31:38] 227 Entering Passive Mode (172,16,14,223,16,245)
[11:31:38] Opening data connection to 172.16.14.223 Port: 4341
[11:31:38] LIST -T
[11:31:59] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[11:32:50] NOOP
[11:32:51] 200 Command okay.

#6 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 02:18 AM

The -T argument is not removed yet. The -T is the complete time switch.

Regards,
Mat

#7 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 02:20 AM

Wait a minute. As hard as I try, I can not remove the -T, even if I use the custom command, which says "LIST" it enters LIST -T

??

Hugo

#8 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 02:26 AM

Here is FlashFXP doing the LIST -L, it works.

[12:21:40] [R] TYPE A
[12:21:41] [R] 200 Type set to A.
[12:21:41] [R] MODE Z
[12:21:42] [R] 200 MODE Z ok.
[12:21:42] [R] PASV
[12:21:42] [R] 227 Entering Passive Mode (172,16,14,223,4,9)
[12:21:42] [R] Opening data connection IP: 58.62.223.223 PORT: 1033
[12:21:43] [R] LIST -al
[12:21:44] [R] 150 Opening ASCII mode data connection for /bin/ls.
[12:21:45] [R] 226 Transfer complete.
[12:21:45] [R] List Complete: 584 bytes in 5.29 seconds (0.1 KB/s)
[12:21:55] [R] PASV
[12:21:56] [R] 227 Entering Passive Mode (172,16,14,223,4,12)
[12:21:56] [R] Opening data connection IP: 58.62.223.223 PORT: 1036
[12:21:57] [R] LIST -T
[12:21:57] [R] 150 Opening ASCII mode data connection for /bin/ls.
[12:21:59] [R] 226 Transfer complete.
[12:21:59] [R] List Complete: 648 bytes in 3.73 seconds (0.2 KB/s)

Hugo

#9 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 02:32 AM

Ah yes the -T switch is automatically added if Serv-U is detected.

Do you have SmartFTP in the exceptions in your software firewall?

Regards,
Mat

#10 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 03:13 AM

Hi,

I run Win 2003 EE R2 x86 with no Windows FW or no Anti-Virus that does port blocking/FW. Remember, FlashFXP and FTPRush work, and they are using the same FTP commands.

Also, UPnP is turned off of the router, and on the SmartFTP client, but thats just my setup.

Hugo

#11 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 03:15 AM

Do you have this problem with every FTP server or just one in particular? Did you try to update the server software to the latest version?

Oh and please post the complete log from both FlashFXP and SmartFTP.

Regards,
Mat

#12 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 03:45 AM

Just this one FTP (other FTP's are fine, which makes you think its the servers problem, not the client)

Yes I have tried the latest beta build (see first post) All what I have done to this point I have tried before posting.

I can only post after im logged in....privacy.

FLASHFXP


[13:39:25] [R] 220-Serv-U FTP Server v6.4 for WinSock ready...
[13:39:25] [R] 220- Welcome to...

REMOVED PERSONAL INFO

[13:39:28] [R] 331 User name okay, need password.
[13:39:28] [R] PASS (hidden)
[13:39:29] [R] 230-ServUPlus 2.2 unregistered. [http://www.dream4dev.com]
[13:39:29] [R] 230-[UL:0B][DL:2.54G][CT:1G][0/60 Sec Cache]
[13:39:29] [R] 230 User logged in, proceed.
[13:39:29] [R] SYST
[13:39:30] [R] 215 UNIX Type: L8
[13:39:30] [R] FEAT
[13:39:31] [R] 211-Extension supported
[13:39:32] [R] CLNT
[13:39:32] [R] MDTM
[13:39:32] [R] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[13:39:32] [R] SIZE
[13:39:32] [R] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[13:39:32] [R] REST STREAM
[13:39:33] [R] XCRC filename;start;end
[13:39:33] [R] MODE Z
[13:39:33] [R] MLST Type*;Size*;Create;Modify*;Win32.ea*;
[13:39:33] [R] 211 End
[13:39:33] [R] CLNT FlashFXP 3.4.0.1145
[13:39:33] [R] 200 Noted.
[13:39:33] [R] CWD /
[13:39:34] [R] 250-
[13:39:35] [R] 250------- ===== *×¢Òâ* Çë¸øÿ¸ö´ÅÅ̱£Áô 1 GB Ê£Óà¿Õ¼ä *×¢Òâ* ====== ------
[13:39:35] [R] 250------- ===== ÄúÕýÔÚ´¦ÓÚ´ÅÅÌ G :\>£¬´Ë´ÅÅÌÏÖÔÚ»¹ÓÐ 10657.22 MB ¿ÉÓÿռä ====== ------
[13:39:35] [R] 250------- ===== *×¢Òâ* Çë¸øÿ¸ö´ÅÅ̱£Áô 1 GB Ê£Óà¿Õ¼ä *×¢Òâ* ====== ------
[13:39:35] [R] 250-
[13:39:35] [R] 250 Directory changed to /
[13:39:35] [R] PWD
[13:39:36] [R] 257 "/" is current directory.
[13:39:36] [R] TYPE A
[13:39:37] [R] 200 Type set to A.
[13:39:37] [R] MODE Z
[13:39:38] [R] 200 MODE Z ok.
[13:39:38] [R] PASV
[13:39:39] [R] 227 Entering Passive Mode (172,16,14,223,5,243)
[13:39:39] [R] Opening data connection IP: 58.62.223.223 PORT: 1523
[13:39:40] [R] LIST -al
[13:39:40] [R] 150 Opening ASCII mode data connection for /bin/ls.
[13:39:41] [R] 226 Transfer complete.
[13:39:41] [R] List Complete: 700 bytes in 5.14 seconds (0.1 KB/s)

SMARTFTP

[13:43:55] 331 User name okay, need password.
[13:43:55] PASS (hidden)
[13:43:56] 230-ServUPlus 2.2 unregistered. [http://www.dream4dev.com]
[13:43:56] 230-[UL:0B][DL:2.54G][CT:1G][17/60 Sec Cache]
[13:43:56] 230 User logged in, proceed.
[13:43:56] SYST
[13:43:57] 215 UNIX Type: L8
[13:43:57] Detected Server Type: UNIX
[13:43:57] FEAT
[13:43:58] 211-Extension supported
[13:43:58] CLNT
[13:43:59] MDTM
[13:43:59] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[13:43:59] SIZE
[13:43:59] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[13:43:59] REST STREAM
[13:43:59] XCRC filename;start;end
[13:43:59] MODE Z
[13:43:59] MLST Type*;Size*;Create;Modify*;Win32.ea*;
[13:43:59] 211 End
[13:43:59] Detected Server Software: Serv-U 5.x/6.x
[13:43:59] CLNT SmartFTP 2.5.1008
[13:43:59] 200 Noted.
[13:43:59] PWD
[13:44:00] 257 "/" is current directory.
[13:44:00] TYPE A
[13:44:01] 200 Type set to A.
[13:44:01] MODE Z
[13:44:02] 200 MODE Z ok.
[13:44:02] PASV
[13:44:03] 227 Entering Passive Mode (172,16,14,223,6,8)
[13:44:03] Opening data connection to 172.16.14.223 Port: 1544
[13:44:03] LIST -T
[13:44:24] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Hugo

#13 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 03:55 AM

Since I have never heard of ServUPlus before it would like to believe that the problem is with the server.

Regards,
Mat

#14 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 04:09 AM

Serv U Plus is just Serv-U with a plug in. Nothing really special just for user administartion via a DB.

http://www.linuxp2p.net/blog/?p=26

Hugo

#15 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 17 April 2008 - 04:38 AM

Did you try to upgrade the Serv-U software on the server side? We have been testing Serv-U since version 3.0 and never noticed a bug.

Regards,
Mat

#16 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 17 April 2008 - 04:46 AM

I dont have control, own or can email the admin of the server.

I would not worry to much as I think this is one of the issues which require max time, for little return.

Just keep it in mind. In the mean time I will use RushFTP and FlashFXP for that server.

Hugo

#17 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 18 April 2008 - 09:24 AM

Hey,

I think I found the problem.

Can you tell me why this happens only with SmartFTP

[13:44:03] 227 Entering Passive Mode (172,16,14,223,6,8)
[13:44:03] Opening data connection to 172.16.14.223 Port: 1544
[13:44:03] LIST -T

Now this is everyother FTP client, Flash,Rush,Core

[13:39:39] [R] 227 Entering Passive Mode (172,16,14,223,5,243)
[13:39:39] [R] Opening data connection IP: 58.62.223.223 PORT: 1523
[13:39:40] [R] LIST -al

I did a packet sniff and found that you are trying to get data from 172,16,14,223!!! Thats not the sevrver.

In CoreFTP is says after:

Opening data connection to 172.16.14.223 Port: 1544
172.16.14.223 -> 58.62.223.223
Opening data connection IP: 58.62.223.223 PORT: 1523
LIST -al

So why does this happen, why doesn't SmartFTP know that the IP is wrong and correct it like the other client?

I'm sure you can fix this now. You must be able to see whats happening.

Hugo

#18 mb

mb

    Developer

  • Administrators
  • 11526 posts

Posted 18 April 2008 - 08:49 PM

There is an option called "Force PASV IP" in the favorite settings. FTP->Connection. Enable it and try again.

#19 hugo.georg

hugo.georg
  • Members
  • 11 posts

Posted 19 April 2008 - 12:06 AM

Hi MB,

Why did that work??? Yippie!!!

You fixed it. The directory loads fine!!

Thank you so much!

I've found the perfect client! I will buy this now as the last issue was fixed.

Thank you

Hugi