SSH

SmartFTP ویژگی‌های زیر از پروتکل Secure Shell (SSH) را پیاده‌سازی می‌کند.

ویژگی‌ها

انطباق با استانداردهای امنیتی

روش‌های احراز هویت

روش‌های احراز هویت زیر پشتیبانی می‌شوند:
  • گذرواژه
    احراز هویت با نام کاربری/گذرواژه و روش تعاملی صفحه‌کلید. درخواست‌های سرور برای تغییر گذرواژه نیز پشتیبانی می‌شوند.
  • کلید عمومی
    فایل کلید (PuTTY، VanDyke SecureCRT، SSH.com، OpenSSH، PEM)، گواهی‌های X.509، گواهی‌های Microsoft Windows از مخزن گواهی یا کارت هوشمند (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    پشتیبانی از پیاده‌سازی Microsoft Windows Kerberos (SSPI) و MIT Kerberos (GSSAPI).
  • مبتنی بر میزبان
    احراز هویت با فایل کلید میزبان یا گواهی.
  • RSA SecurID
    احراز هویت دومرحله‌ای RSA SecurID.

رمزگذاری‌ها

فشرده‌سازی‌ها

روش‌های تبادل کلید

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

الگوریتم‌های کلید عمومی

HMACs

افزونه‌ها