SSH

SmartFTP implementa las siguientes características del protocolo Secure Shell (SSH).

Funciones

Cumplimiento de las normas de seguridad

Autenticaciones

Se ofrecen los siguientes métodos de autenticación:
  • Contraseña
    Nombre de usuario/contraseña y autenticación interactiva mediante teclado. También ofrece la posibilidad de solicitar cambios de contraseña del servidor.
  • Clave pública
    Archivo de clave (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), certificado X.509, certificados de Microsoft Windows de un almacén certificados o de una tarjeta inteligente (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Compatibilidad con las implementaciones Microsoft Windows Kerberos (SSPI) y MIT Kerberos (GSSAPI).
  • Basado en hosts
    Autenticación mediante un archivo de tecla del host o un certificado.
  • RSA SecurID
    RSA SecurID autenticación en dos fases.

Cifrados

Compresiones

Métodos de intercambio de claves

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmos de clave públicas

HMACs

Extensiones