SSH

SmartFTP implements the following features of the Secure Shell (SSH) protocol.

Features

Security Standard Compliance

Authentications

The following authentication methods are supported:
  • Password
    Username/password and keyboard-interactive authentication. Also supports server password change requests.
  • Public Key
    Key file (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509 certificates, Microsoft Windows certificates from a certificate store or a Smart Card (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Support for Microsoft Windows Kerberos (SSPI) and MIT Kerberos (GSSAPI) implementations.
  • Host Based
    Authentication with a host key file or a certificate.
  • RSA SecurID
    RSA SecurID two-factor authentication.

Encryptions

Compressions

Key Exchange Methods

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Public Key Algorithms

HMACs

Extensions