SSH

SmartFTP stellt die folgenden Funktionen des Secure Shell (SSH) Protokolls zu Verfügung.

Funktionen

Sicherheit Standard Einhaltung

Authentifikationsmethoden

Die folgenden Authentifizierungsmethoden werden unterstützt:
  • Passwort
    Benutzername/Passwort und Tastatur-Interaktive Authentifizierung. Erlaubt ebenfalls entfernte Passwortänderungsanfragen.
  • Öffentlicher Schlüssel
    Schlüsseldatei (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509 Zertifikate, Microsoft Windows Zertifikate vom Zertifikatspeicher oder einer Smart Card (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Unterstützung für die Implementierungen Microsoft Windows Kerberos (SSPI) und MIT Kerberos (GSSAPI).
  • Hostbasierend
    Authentifizierung über entfernter Schlüsseldatei und Zertifikat.
  • RSA SecurID
    RSA SecurID Zwei-Faktor Authentifizierung.

Verschlüsselungsmethoden

Kompressionsmethoden

Schlüsselaustauschmethoden

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Public-Key Algorithmem

HMACs

Erweiterungen