SSH

SmartFTP implementuje následující funkce protokolu Secure Shell (SSH).

Funkce

Soulad s bezpečnostními standardy

Ověřování

Podporovány jsou následující metody ověřování:
  • Heslo
    Ověřování uživatelským jménem a heslem i interaktivní ověřování z klávesnice. Podporuje také požadavky serveru na změnu hesla.
  • Veřejný klíč
    Soubory klíčů (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), certifikáty X.509, certifikáty Microsoft Windows z úložiště certifikátů nebo čipové karty (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Podpora implementací Microsoft Windows Kerberos (SSPI) a MIT Kerberos (GSSAPI).
  • Na základě hostitele
    Ověřování pomocí souboru klíče hostitele nebo certifikátu.
  • RSA SecurID
    Dvoufaktorové ověřování RSA SecurID.

Šifrování

Komprese

Metody výměny klíčů

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmy s veřejným klíčem

HMACs

Rozšíření