SSH

SmartFTP изпълнява следните функции на протокола Secure Shell (SSH).

Функции

Съответствие със стандартите за сигурност

Удостоверяване

Поддържат се следните методи за удостоверяване:
  • Парола
    Удостоверяване с потребителско име/парола и интерактивно чрез клавиатурата. Поддържа и заявки от сървъра за промяна на паролата.
  • Публичен ключ
    Файл с ключ (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), сертификати X.509, сертификати на Microsoft Windows от хранилище за сертификати или смарт карта (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Поддръжка на реализациите Microsoft Windows Kerberos (SSPI) и MIT Kerberos (GSSAPI).
  • На базата на хост
    Удостоверяване с файл с ключ на хоста или сертификат.
  • RSA SecurID
    Двуфакторно удостоверяване RSA SecurID.

Шифриране

Компресия

Методи за обмен на ключове

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Алгоритми с публичен ключ

HMACs

Разширения