SSH

ينفذ SmartFTP الميزات التالية لبروتوكول Secure Shell (SSH).

الميزات

التوافق مع معايير الأمان

المصادقات

طرق المصادقة التالية مدعومة:
  • كلمة المرور
    مصادقة اسم المستخدم/كلمة المرور والمصادقة التفاعلية عبر لوحة المفاتيح. يدعم أيضًا طلبات تغيير كلمة مرور الخادم.
  • المفتاح العام
    ملف مفتاح (PuTTY وVanDyke's SecureCRT وSSH.com وOpenSSH وPEM)، شهادات X.509، شهادات Microsoft Windows من مخزن شهادات أو بطاقة ذكية (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    دعم تطبيقي Microsoft Windows Kerberos (SSPI) وMIT Kerberos (GSSAPI).
  • اعتمادا على المضيف
    المصادقة باستخدام ملف مفتاح مضيف أو شهادة.
  • RSA SecurID
    مصادقة ثنائية العامل RSA SecurID.

تشفيرات

الضغط

طرق تبادل المفاتيح

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

خوارزميات المفتاح العام

HMACs

ملحقات