Jump to content


Issue Information

  • #000079

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

sftp authentication troubles when using login dialog

Posted by meisterkaiser on 09 June 2010 - 05:04 PM

Changed the Login Options from an existing favourite, I no langer wanted to store the clients' pw.
It is an SFTP connection.

Favourite options:
General, LoginType: Username&Password
Password field is empty

- connect to server (open favourite)
- login dialog (Update: Session)
- enter PW & OK
- error in Log: user authentication failed
- press abort
- press refresh: now you're connected to the server!?! But:
- every transfer (both ways) gets stuck in a "retry at ..." loop

if I store the pw in the favourite again, transfers work immediately after saving the favourite (without reconnecting).

If I remove the pw and save the favourite again, transfers still work.

Open favourite after restarting SmartFTP, login dialog appears -> same problems as described above.

And yeah - no spelling errors involved -> pw gets copied via clipboard from pwSafe Software (KeePass).

It took me a few days to track the reason down to the changed login options, unfortunately this is the second time in weeks the program failed me, right when I'm on a tight schedule :-(


System Info:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2211 MHz
Total Memory : 2047 MB
Free Memory : 1055 MB

+- SmartFTP ---------------------------
Version : 4.0.1120.0
Time Stamp : 2010-06-08 14:12:54
Platform : x86
Id : 400060093
Maintenance : 2011-07-22
Days in use : 1139

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Updating status to: Awaiting Feedback

Unfortunately I cannot follow exactly what is happening in your case. However one thing to remember is if the username/password is in the session cache (if you set the update action to Session in the Login dialog) the login information won't get removed from the cache until SmartFTP is restarted.

>press refresh: now you're connected to the server!?! But:
Are you sure you are connected to the server and not just the directory listing from the cache is displayed in the view?

I made the following changes for the next build:
- If the Update action is set to Favorite in the Login Dialog the login information are removed from the session cache (if there was any)
- If the Show Login Dialog favorite setting is disabled, the Transfer Queue no longer uses the information from the session cache


meisterkaiser
Jun 10 2010 08:45 PM
> Are you sure you are connected to the server and not just the directory listing from the cache is displayed in the view?

Pretty much, yes. I disabled caching in the favourite and the default favourite.
It makes sense that the login info remains in the session and explains why it keeps working to the next restart.

Not sure if your changes will affect my problem since I did not use "Favourite" for the update action.
But I agree that it is a very peculiar situation - and I have no other clues to offer so far :-(
I'll test again when the new built is available, maybe this will shed some more light ...

The new version is available now:
http://www.smartftp.com/download

Please give it a try.

Thanks
Mat


meisterkaiser
Jun 15 2010 07:40 AM
Same behaviour with the new built, still have to store the pw in the favourite to make transfers work.

Updating status to: Confirmed
Issue fixed in: 4.0.1122.0

Updating status to: Fixed

Install the latest version: http://www.smartftp.com/download


meisterkaiser
Jun 28 2010 08:20 AM
Problem fixed, excellent, thanks a lot!





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users