Jump to content


Photo

high CPU loading


  • Please log in to reply
12 replies to this topic

#1 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 08:58 AM

SmartFTP 4.0.1054.0 No language pack installed. AMD Athlon 64 x2 4600+. If there is some speed limit enabled then CPU loading by SFTP (during uploading) is over 50%. What is the problem?

#2 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 02:26 PM

Post the system information from the menu: Help->About "System Information"

What protocol are you using? Post the log from the transfer.

Thanks
Mat

#3 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 07:34 PM

screenshot:Posted Image

Post the system information from the menu: Help->About "System Information"


+- System -----------------------------
Microsoft Windows 7 Ultimate Edition 
 (Build 7600)

CPU Speed           : 2411 MHz
Total Memory        : 2047 MB
Free Memory         :  956 MB

+- SmartFTP ---------------------------
Version             : 4.0.1054.0
Time Stamp          : 2009-10-06 19:54:07
Platform            : x86
Unlicensed
Days in use         : 20

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version             : 8.0.7600.16385

+- Winsock ----------------------------
Winsock             : 2.2

What protocol are you using?

FTP

Post the log from the transfer.

Where can I find it?

#4 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 08:08 PM

For testing purpose please remove the transfer limit and then try again.

Thanks
Mat

#5 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 08:17 PM

No problem:
Posted Image

#6 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 08:50 PM

Hm so far I'm not able to reproduce it.

Does it happen if you have a speed limit but only use 1 Worker instead of 10?

Do you have other products as net limiter etc installed?

Regards,
Mat

#7 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 09:08 PM

Something like this:
Posted Image

Do you have other products as net limiter etc installed?

Of course I have. And there is no such a problem with any other application.
For example: CuteFTP, FileZilla.

Edited by eugenes, 13 October 2009 - 09:10 PM.


#8 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 09:55 PM

I think I know where the problem is coming from.

I wasn't asking about other applications in general but ones that hook into Winsock. Typically these are software firewalls, programs to control the max bandwidth (netlimiter) and antivirus products.

Regards,
Mat

#9 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 10:06 PM

I've turned off Kaspersky Internet Security and the problem has gone. But SFTP was added in "trusted applications" in KIS and the function "do not control traffic" for SFTP was on. So is it possible to use KIS and SFTP in limited mode at the same time? What should I do for it?

#10 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 10:29 PM

My recommendation is to drop Kaspersky and use the firewall that comes with Windows 7. I recommend you report the bug with the Kaspersky firewall to the vendor.

#11 eugenes

eugenes
  • Members
  • 8 posts

Posted 13 October 2009 - 10:30 PM

Thank you.

#12 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 October 2009 - 11:28 PM

I will try implement a workaround that should at least help to keep the cpu usage lower.

#13 mb

mb

    Developer

  • Administrators
  • 11654 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 26 October 2009 - 08:56 PM

Please test it with the latest version:
http://www.smartftp.com/download

Thank you
Regards,
Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users