Jump to content


Photo

Smart closes by DEP problem


This topic has been archived. This means that you cannot reply to this topic.
19 replies to this topic

#1 spartan

spartan
  • Members
  • 10 posts

Posted 05 October 2009 - 10:02 AM

I´m using Smart years ago with license. Today I have a new problem when i upload files the program is closed by vista due to DEP (Data Execution Prevention) error.
I thing that is caused by file preview. I install latest version of smart, to verify if is compatible with DEP, but error continues.

How to solve the problem?

thank you.

#2 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 05 October 2009 - 02:34 PM

Install the latest version:
http://www.smartftp.com/download

Then post the system information from the menu: Help->About "System Information"

Regards,
Mat

#3 Seth

Seth
  • Members
  • 3 posts

Posted 05 October 2009 - 02:58 PM

I started getting this error today also. I had a 3.xx something version and went and upgraded to the newest version. Problem still continues. I have a file called index.html that whenever I click on it it crashes SmartFTP and says that it closed because of the DEP protection. I renamed the file. Moved it. Created a brand new blank file (using notepad) and named it index.html and 1234.html with the same results. It seems like anything I create (with .html) now crashes the program. I can click on txt files, but not .html files. I created a new txt file, typed blah blah and saved it as test.txt and test.html. When I click on the txt file through SmartFTP it previews fine. When I click on the .html file, it crashes.. Any advise? I have logmein.com on the computer if a remote view helps for an admin...

Seth Anderson
Here's my info:

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
Service Pack 2 (Build 6002)

CPU Speed : 2300 MHz
Total Memory : 2047 MB
Free Memory : 2041 MB

+- SmartFTP ---------------------------
Version : 4.0.1052.0
Time Stamp : 2009-10-03 00:50:19
Platform : x86
Id : 400110711
Maintenance : 2010-07-08
Days in use : 17

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 8.0.6001.18813

+- Winsock ----------------------------
Winsock : 2.2

#4 spartan

spartan
  • Members
  • 10 posts

Posted 05 October 2009 - 03:00 PM

Install the latest version:
http://www.smartftp.com/download

Then post the system information from the menu: Help->About "System Information"

Regards,
Mat



+- System -----------------------------
Microsoft Windows Vista Business Edition
Service Pack 2 (Build 6002)

CPU Speed : 2493 MHz
Total Memory : 2047 MB
Free Memory : 1044 MB

+- SmartFTP ---------------------------
Version : 4.0.1052.0
Time Stamp : 2009-10-03 00:50:19
Platform : x86
Id : 400076934
Maintenance : 2009-09-14
Days in use : 35

+- Language ---------------------------
es-ES

+- Internet Explorer ------------------
Version : 8.0.6001.18813

+- Winsock ----------------------------
Winsock : 2.2

#5 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 05 October 2009 - 03:30 PM

Thanks. Please create a crash dump and I can look at it:
http://www.smartftp....orts-f2594.html

Regards,
Mat

#6 Seth

Seth
  • Members
  • 3 posts

Posted 06 October 2009 - 08:40 PM

Once the 207Mb zip file finishes uploading it will be in the folder here: http://sethedward.com/SMARTFtp/
(I have fast-for-the-middle-of-nowhere wireless internet so it will likely take an hour or so to finish)

Seth

#7 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 06 October 2009 - 09:03 PM

Thank you. Did you already try it with the latest build (1054) we have just released?

Regards,
Mat

#8 spartan

spartan
  • Members
  • 10 posts

Posted 07 October 2009 - 07:09 AM

Thank you. Did you already try it with the latest build (1054) we have just released?

Regards,
Mat


Yes Mat, when had problem, first I done is install last version, and the problem remains. Yesterday was imposible to work with smartftp, when I select .html archives in local browser windows stop program due to DEP problem.

#9 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 07 October 2009 - 01:31 PM

spartan: Please post the system information from the menu: Help->About "System Information"

#10 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 07 October 2009 - 05:40 PM

Seth: I looked at your crash dump and here is the stack trace:

28000000()
inetcomm.dll!OE_SafeReleaseAndNullPtr<IFontCache>() + 0x17 bytes
inetcomm.dll!CHtmlPreviewer::IsMessagePhishing() + 0x121 bytes
inetcomm.dll!CBody::_InitPhishing() + 0x77 bytes
inetcomm.dll!CBody::OnDocumentReady() + 0x1c2 bytes
inetcomm.dll!CBody::Exec() + 0x57 bytes
mshtml.dll!6aa7ec57()
[Frames below may be incorrect and/or missing, no symbols loaded for mshtml.dll]
mshtml.dll!6a9e48ea()
inetcomm.dll!CPrivateUnknown::CUnkInner::Release() + 0x14 bytes
inetcomm.dll!CPrivateUnknown::Release() + 0x11 bytes
064699c0()
mshtml.dll!6aa76a27()
mshtml.dll!6aa80442()
mshtml.dll!6aa81348()
user32.dll!_NtUserRedrawWindow@16() + 0xc bytes

You can see that the crash happens in the html control in the preview pane.
The same issue has been reported by another user. He then reported it to MS and they did - without any analysis - just blame our product for it:
http://social.techne...09-705519469fcb

Later the user was not able to reproduce it anymore so the case got closed at MS.

Regards,
Mat

#11 spartan

spartan
  • Members
  • 10 posts

Posted 07 October 2009 - 05:49 PM

spartan: Please post the system information from the menu: Help->About "System Information"


I post this already in begining of post.

Yes mainly smart is closed when you have preview panel, but also without it in some cases.

The last post about MS, I don't understand the solution no arrange program. Could you explain more for ruders with english?

#12 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 07 October 2009 - 05:59 PM

spartan: I don't know if your problem is related to the one from Seth. Maybe it's the best you start a new thread.
And in this thread please post the system information again as requested.
Thanks.

#13 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 07 October 2009 - 06:23 PM

Seth: I can reproduce the crash on Windows 2008. But it's definitively a bug in Windows because the crash also happens in Windows Explorer (The preview surrogate host crashes with a DEP).
To reproduce it on Windows 2008 SP2 with Windows Explorer:
1. Enable Preview pane if it is not enabled yet. Otherwise go to 4
2. Click on Organize button
3. a) Layout->Preview Pane
3. b) If Preview Pane is not in the sub menu, click on Folder and Search Options instead. In the Task paragraph enable Show previews and filters
Go to 3. a)
4. Select .html file
5. The preview surrogate host crashes as shown below

Posted Image

#14 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 08 October 2009 - 07:12 AM

The next version will also use a COM surrogate host to load the preview handlers. This way only the host process will crash and it won't take down SmartFTP with it. The behavior will then be the same as in Windows Explorer.

#15 Seth

Seth
  • Members
  • 3 posts

Posted 08 October 2009 - 03:30 PM

You can see that the crash happens in the html control in the preview pane.


If by "you" you mean me, I can't see anything of the sort... lol

I reinstalled the latest version (now have 1054 upgraded from 1052) and the problem still continues. I closed the preview pane window and can now be productive again... I guess I'll wait a few weeks and see if windows puts out a fix or SMART a work around.. (Windows? as the cause of the problem? nah! it couldn't be? really? :D

Seth

#16 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 08 October 2009 - 06:18 PM

The workaround is disable the Preview Pane. Or with the new version of SmartFTP, only the host process crashes but not the app itself. The bug is in Windows and since the bug probably has been fixed in Windows 7/20008 R2 most likely no hotfix will be released for the older versions.

#17 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 26 October 2009 - 11:48 PM

Please test it again with the latest version of SmartFTP:
http://www.smartftp.com/download

It includes the workaround I have mentioned.

Regards
Mat

#18 spartan

spartan
  • Members
  • 10 posts

Posted 02 November 2009 - 11:39 AM

spartan: I don't know if your problem is related to the one from Seth. Maybe it's the best you start a new thread.
And in this thread please post the system information again as requested.
Thanks.


This is my system information. The problem now, is that I can´t use smart, because tell me that maintenance has expired.
When I purchase the software though that when you purchase you can use it for the time as you want this version. Don´t know why I have to pay every year.

Now I can test it, and don't know if will crash as now. So why purchase again for a soft that don't work if I expected when I know and try years ago?

Thankyou.



+- System -----------------------------
Microsoft Windows Vista Business Edition
Service Pack 2 (Build 6002)

CPU Speed : 2493 MHz
Total Memory : 2047 MB
Free Memory : 1044 MB

+- SmartFTP ---------------------------
Version : 4.0.1052.0
Time Stamp : 2009-10-03 00:50:19
Platform : x86
Id : 400076934
Maintenance : 2009-09-14
Days in use : 35

+- Language ---------------------------
es-ES

+- Internet Explorer ------------------
Version : 8.0.6001.18813

+- Winsock ----------------------------
Winsock : 2.2

#19 spartan

spartan
  • Members
  • 10 posts

Posted 03 March 2010 - 07:51 PM

Thank you to techs, I purchase the a new license and the problem in my side is solved.

#20 mb

mb

    Developer

  • Administrators
  • 11718 posts

Posted 03 March 2010 - 10:11 PM

Thank you for your feedback.